Some users experiencing login issues
Incident Report for TimeFiler
Resolved
This is now resolved for the applicable users.
Posted Feb 27, 2024 - 14:18 NZDT
Update
It is not a wider outage - the issue is isolated to specific customers and we continue to investigate the cause for those users.

If you or your users experiences an issue, please report it to support@timefiler.com as usual.
Posted Feb 27, 2024 - 13:30 NZDT
Investigating
A handful of customers have reported getting an error in TimeFiler. We are looking into whether this is a wider issue.
Posted Feb 27, 2024 - 13:12 NZDT
This incident affected: Main Application.